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Overview 

The Task recorder that is included with Microsoft Dynamics AX lets you quickly create documentation 
of a business process. Task recorder can create Microsoft Word documents and a video that you can 
use to document how to perform a task. You can also specify a template to use when you create a 
document, so that all the documents that you create have the same look and feel.  

The updated Task recorder that is available in a hotfix has an advanced mode. This mode captures 
additional metadata that lets you create a file that can be uploaded to Business process modeler in 
Lifecycle Services for Microsoft Dynamics AX. This file includes cross-functional flowcharts and 

activities that you can modify to identify business requirements and generate implementation 
artifacts.  

Task recorder update is available for Microsoft Dynamics AX 2012 R2, Microsoft Dynamics AX 2012 
Feature Pack, and Microsoft Dynamics AX 2012. 

Downloading and installing Task recorder 

The updated Task recorder is available as a hotfix. The hotfix consists of a client update and a model 
file. You must install the client update on all Microsoft Dynamics AX 2012 clients.  

Knowledge Base article 2863182 contains installation files for the following versions: 

 Microsoft Dynamics AX 2012 and Microsoft Dynamics AX 2012 Feature Pack: 

http://go.microsoft.com/fwlink/?LinkId=309910 

 Microsoft Dynamics AX 2012 R2: http://go.microsoft.com/fwlink/?LinkId=309911 

Basic and advanced mode 

The updated Task recorder has two modes: 

 Basic mode – This mode generates a Word document and a video recording of the selected 
business processes in a predefined shared folder.  

 Advanced mode – Use this mode to record, upload, and share your business processes to 
Business process modeler in Lifecycle Services for Microsoft Dynamics AX. Advanced mode can 
generate a package file that can be uploaded to Business process modeler. The package file 

contains hierarchy, process, and Application Object Tree (AOT) metadata, and also task 
documents and videos.  

Prerequisites and supported environments 

If you want to use the updated Task recorder, the following products are required: 

 Windows Media Player. For more information about Windows Media Player, see 
http://windows.microsoft.com/en-us/windows/windows-media-player.  

 Word installed on the computer where you want to use Task recorder. If you do not have Word 
installed, Task recorder generates an XML file. For more information about Word and Microsoft 
Office, please see http://office.microsoft.com. 

http://go.microsoft.com/fwlink/?LinkId=309910
http://go.microsoft.com/fwlink/?LinkId=309911
http://windows.microsoft.com/en-us/windows/windows-media-player
http://office.microsoft.com/
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 A Microsoft Dynamics AX client and an Application Object Server (AOS) server:  

 In basic mode: The Microsoft Dynamics AX client and AOS server can be installed on different 
computers. 

 In advanced mode: The Microsoft Dynamics AX client and AOS server must be installed on the 

same computer.  

In addition, all users who use Task recorder must have write access to a central file share where the 
recording output is saved. 

If you want to use advanced mode, there are additional requirements: 

 You must have Microsoft Office installed. 

 The AOS service account must have write access to the document folder share. 

Basic mode in Task recorder 

Configure Task recorder for basic mode 

To configure Task recorder for basic mode, follow these steps:  

1. On the File menu, click Tools > Task recorder to open the Task recorder form. 

2. On the Settings tab, click Parameters. In the Task recorder parameters form, in the 
Recording file path field, select the location in which to generate the recording files.  

3. To use a template when you create a document, in the Template file path field, select a 

template location. 
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Record a task in basic mode 

To record a task in basic mode, follow these steps: 

1. On the File menu, click Tools > Task recorder to open the Task recorder form. 

2. If no framework and industry are selected, follow these steps: 

1.  On the Action Pane, click the Start button. When you are prompted to create a default 
framework and industry, click OK. 
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2. Select the root node, click New node, enter the name and description of the task to record, 
and then click Save. The task is created under the root node. 

 

–or– 

If you have selected a framework and industry, expand and select the node to record.  

3. Click Start. The Task recorder form is minimized.  

4. Complete the task in Microsoft Dynamics AX 2012. The maximum recording length is 10 minutes. 

5. When the recording is completed, expand the minimized Task recorder form, and then click 
Stop. The video and the Word document are saved in the folder that you selected in the 
Recording file path field in the Task recorder parameters form.  

6. Optional: You can re-record a node; or you can select a node and then click Clear node, which 
removes the associated files. 

7. Optional: To view the video, navigate to the shared folder that you selected in the Recording file 

path field in the Task recorder parameters form. Open the subfolder that is named in the 
format <Framework>_<Industry>. For example, if your process name is Create/Distribute 
purchase orders, the folder name that is created after recording is Create_4212B2BB. 
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Advanced mode in Task recorder  

Configure Task recorder for advanced mode 

To configure Task recorder for advanced mode, follow these steps: 

1. On the File menu, click Tools > Task recorder to open the Task recorder form. 

2. On the Action Pane, on the Settings tab, click Industry to configure a new industry. 

 

3. Enter information about the industry, and then close the SysRecorder industry form. 
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4. In the Task recorder form, on the Settings tab, click Framework to configure a new 
framework. Enter information about the framework, and then close the SysRecorder framework 
form. 

 

5. In the Task recorder form, on the Settings tab, click Hierarchy levels to configure the levels 
for the framework and industry. To capture information for Business process modeler, select 

Advanced for the combination of a framework and an industry. Close the Hierarchy levels form. 
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Record a task in advanced mode 

To record a task in advanced mode, follow these steps: 

1. Open Microsoft Dynamics AX as an administrator. (Right-click the Microsoft Dynamics 2012 AX 
icon, and then select Run as Administrator.) 

2. On the File menu, click Tools > Task recorder to open the Task recorder form. 

3. Select the framework and industry, and then expand and select the node to record.  

4. For the selected node, in the Module field, select a module. 

  

5. Click Start. The Task recorder form is minimized.  

6. Complete the task in Microsoft Dynamics AX 2012. The maximum recording length is 10 minutes. 

7. When the recording is completed, expand the minimized Task recorder form, and then click 
Stop. The video and the Word document are saved in the folder that you selected in Recording 
file path field in the Task recorder parameters form. 

8. Optional: You can re-record a node; or you can select a node and then click Clear node, which 
removes the associated files. 

9. Optional: After you have finished recording, the selected node displays a blue arrow. You can 

select that node and then click Document to generate a step-by-step Word document.  

10. Optional: To view the video, navigate to the shared folder that you selected in the Recording file 
path field in the Task recorder parameters form. Open the subfolder that is named in the 

format <Framework>_<Industry>. For example, if your process name is Create/Distribute 
purchase orders, the folder name that is created after recording is Create_4212B2BB. 
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Generate a package for Business process modeler in Lifecycle 

Services for Microsoft Dynamics AX 

The advanced mode of Task recorder generates artifacts that can be uploaded to Business process 
modeler in Lifecycle Services for Microsoft Dynamics AX. You can define, record, and upload your 
business processes, and share them with teams, with organizations, and globally. To generate a 

package for Business process modeler, follow these steps: 

1. Define your organization’s business process hierarchy in Task recorder advanced mode. 

2. Generate the recordings for the selected nodes. 

3. After the processes have been recorded for a framework, in the Task recorder form, click Build 
package.  

Note: Only one person should click this button for a framework. 

 

Clicking Build package starts a batch job that processes the files. The batch job might take a 

long time.  

After the batch job is completed, an .axbpm file is generated in the folder that you specified in the 
Task recorder parameters form. The format of the file name is 

<Framework>_<Industry><ddmmyyyyhhmm>.axbpm. 

This file is what is uploaded to Business process modeler. 

Upload the business process maps to Business process modeler 

The Business process modeler (*.axbpm) files that are generated by Task recorder can be uploaded to 
Business process modeler in Lifecycle Services for Microsoft Dynamics AX. Users can then explore and 
modify the recorded business processes.  
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To upload the business process files, follow these steps:  

1. Sign in to Microsoft Dynamics Lifecycle Services. On the Organization workspace, select a 
project. On the Project home page, click the Business process modeler tile.  

2. On the Business process library page, in the My projects or Corporate library section, click 

Upload.  

 

 If you upload your business process package to My projects, the business processes can be 
viewed only by you or by the users that you give access to.  

 If you upload your business process package to the Corporate library section, the business 
processes can be viewed by all users from your organization. 

 If you upload a business process package to My projects, you can right-click and then select 
Promote on the app bar. This makes the business processes available in the Corporate 

library section. Only the administrator can approve these promotion requests. You can also 

promote business processes from the Corporate library section to the Global library 
section. Only Microsoft can approve these promotion requests. 
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3. On the Administration page, in the New section, select the industry, and then enter a name and 
description. Click the Upload button, select the .axbpm file, and then click OK. The file is 
uploaded.  

 

You can view the status of the business process upload on the Administration page.  

 

After the business process package has been uploaded, you can view the business process framework 
from the Business process library page. 

Uploading and creating business process data 

Users can create data for the processes inside Task recorder in two ways: 

 Manually 

 By using the Microsoft Excel upload function 

In both cases, users must have configured the framework, industry, and framework levels in the Task 

recorder parameters form. 
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Create business process data manually 

1. On the File menu, click Tools > Task recorder to open the Task recorder form. 

2. Select a framework and industry, and then select a node. 

3. Click New node. Enter information about the node, and then click Save.  

  

4. Optional: You can select nodes and then click New node to create child nodes.  

5. Optional: You can use the Move up, Move down, and Delete node buttons to modify nodes. 
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Upload business process data by using Excel 

1. Save the Excel template that is included in the Task recorder hotfix. To find the Excel file, open 
the Microsoft Dynamics AX project \Projects\Shared\SysTaskRecorderPlus, and export this file 
from the Microsoft Dynamics AX resource file as shown in the following screenshot. This has to be 
done by a Microsoft Dynamics AX administrator or developer. 

 

2. Open the template in Excel, and enter the following data:  

 ID  

 Process name  

 Process description  

 Parent ID 

 Framework name 

 Framework level 

 Group 

 Module 

 Usage profile  

The values that you enter for the framework name, framework level, and group must also exist in 
the forms that are opened from the Task recorder parameters form. 

 

3. After you enter information into the template, log on to Microsoft Dynamics AX.  

4. On the File menu, click Tools > Task recorder to open the Task recorder form. 
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5. Click Import data, and then enter the file name. Click Validate and then Import hierarchy. 
The data is imported into Task recorder. 
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